A Linuxon játszás helyzete 2017-ben

Tags:

0

A szombati nap borús, esős volt, és kellett már egy kikapcsolós hétvége. Ezért a szombati napot játékkal töltöttem, mégpedig Linuxon. Gondoltam nem lesz nehezebb egy jót játszani, mint 7 éve, de sajnos tévedtem. A rossz élményhez valószínűleg jócskán hozzátesz, hogy a Lenovo E430 laptopom az Nvidia 710M kártyával idén lesz 4 éves. Előbb-utóbb el kell gondolkozni a cserén.

A hétvégén a Dirt Rally ingyenes volt Steamen, a Feral Interactive-nak köszönhetően már Linuxon is elérhető a játék. Ez egy elég új kiadás, 2015 vége, 2016 eleje, ezért bizonytalan voltam hogyan muzsikál a laptopon. Az ingyenes lehetőségnél nincs jobb alkalom a teljesítmény kipróbálására, hamar lejött és hamar el is indult. És itt jött a meglepetés, használhatatlanul lassú volt a főmenü. Jó sok türelem árán sikerült elnavigálni a benchmarkig, amiben viszont elérte a játék a 20 FPS-t. Jött a guglizás, és kiderült, hogy másnak is van ezzel gondja, és a főmenü háttérvideóját le lehet cserélni egy állóképre. Ezzel a főmenü gondja megoldva, de az élvezetes játékhoz mégis kevés volt a 20 FPS, ezért a Dirt Rally-t nem most fogom megvenni.

A második játék, amivel a szombatot eltöltöttem volna a Mount & Blade: Warband. Ez a játék 2010-ben látta meg a napvilágot, és 2014-ben lett kiadva Linuxra. Már a szombati nap előtt is beletoltam 80-90 óra játékot, elméletileg mindennek simán kellett volna mennie. De nem ment, kb. 15 percenként belassul a játék 30 másodpercre, aztán minden megy tovább szépen. Elsőnek arra gyanakodtam, hogy megsérültek a játék fájljai, ezért Steamben lefuttattam az ellenőrzést, ki is írta, hogy kb. 3600 fájl hibás. Be is tette a letöltések közé, letöltötte, majd hibával megállt. Újrapróbáltam és újra megállt ugyanazzal a hibával. Újra guglizás, és kiderült, hogy ez egy NTFS-hez kapcsolódó hiba, a Linuxos Steam kliensnek a decemberi frissítés óta gondja van ezzel. Megoldás nincs, workaroundként hozzá kell adni a uid és gid kapcsolókat az adott NTFS partícióhoz az fstabban. Ezután ez a hiba megoldódott, működött a frissítés. A játékfájlok most már épek, de az eredeti hiba még fenn állt.

A játékfájlok ellenőrzése után a második gondolatom az volt, hogy új monitorom van, ami 1920×1080-as felbontáson működik, hátha ezt nem bírja kihajtani a laptop. Nem gond, Steamben ki kell választani a játék helyett az MBW beállítóját, amiben a felbontást be lehet állítani. Csakhogy ez nem nyílik meg. Újabb guglizás, természetesen már ebbe is belefutott valaki, és van rá gyógyír. A gondot az okozza, hogy a játékkal érkező Qt libek nem kompatibilisek az Ubuntu 14.04 és újabb kiadásokkal érkező Qt-vel. Ezért le kell cserélni a játék mappájában lévő libeket a rendszer libjeivel és voilà, működik a beállító programocska. A felbontást átállítottam 720p-re, de az időnkénti lassulás még mindig jelentkezik.

Több ötletem már nem volt, ezért rákerestem magára a lassulásra, van is rá tipp, hogy a részecske rendszer lehet a ludas. A különböző effekteket csak a particle_systems.txt módosításával lehet kikapcsolni, 0-ra is tettem minden patával kapcsolatos effektet, de a gond makacsul tartja magát. Kikapcsoltam az összes részecskét a menüből, az sem segített, és még mindig gond van.

A fenti kaland jól összefoglalva a Linuxon játszás élményét 2017-ben. Hiba hegyek, hibákra Google-ben rákeresni, megoldást találni, alkalmazni, és menni tovább amíg az összes hiba el nem fogy. Nem lenne ezzel gond, ha a hibajavítások belekerülnének előbb-utóbb a játékba. De nagyon kevés esélyt látok, hogy a Mount & Blade csapatában bárkit is izgasson, hogy Ubuntu 12.04-nél frissebb rendszeren senki nem tudja megnyitni a beállító alkalmazást.

Frissítés (május 22.): kiderült, hogy az Nvidia driver akadt össze valamivel. Próbáltam újabbat, régebbit, de el sem tudtam indítani a jól bevált Bumblebee segédlettel. Az lett a vége, hogy újratelepítettem az Ubuntu 16.04-et, ami után újra sikerült beüzemelni a Bumblebeet, és a Mount & Blade sem lassul be.

Hozzászólás írása

(kötelező)
(kötelező)